Psi4 installation

I am trying to install psi4 via anaconda, using the command: conda install -c psi4 psi4. However, I am getting an error saying Solving environment: failed with …, trying with … How can I install psi4 via anaconda? Is there something else that I need to install prior to psi4 or something that I need to remove?

Thanks in advance

For the record, the recommended conda install instructions are here.

Have you tried making a new conda environment for Psi?

Yes, I have tried that. I want psi4 to run into another program called FFParam and I can’t seem to find a proper solution.

What’s the output of conda list?

I also recommend creating a new conda environment with only FFParam and Psi4, and seeing if that works. There may be a conflict with something else in this environment.

Hi everyone!
I am having the same issue as Kostantina, trying to use FFparam.
In the FFparam website you are guided to install a bunch of libraries and modules, however, when the time comes for Psi4 to be installed, conda finds conflicting packages (matplotlib-base, pandas, cffi, rdkit, xz, cairo, paramiko etc etc…).

If I install psi4 in my “base” environment, everything works just fine, but it is impossible to install it in the “ffpenv”, even if I made sure the python versions are exactly the same (3.7.0) in both environments.

Thank you!

What system are you trying to install this on? On my Mac, I can’t even make it past the freeglut install. (It looks like that’s Linux and Windows only.) I can’t even attempt to debug this.

I’m on Ubuntu 18.
The thing is you can’t install psi4 on ffparam environment as it messes up with the python modules, regardless of how you installed them.

Tomorrow I will try to install first psi4 in its own environment and then try to install ffparam on top of the psi4 environment and see how it goes.

To give something a bit more actionable, here’s a minimal series of conda commands causing a problem:

conda create -n ffpenv python=3.7
conda install -n ffpenv -c conda-forge libblas
conda install -n ffpenv -c psi4 psi4

This is a simplified version of the actual commands FFParam wants.

For conda issues, I defer to @loriab.

I have managed to install and run psi4 (and gaussian) and to run a job.

Unfortunately, for some reasons, the same programs can’t be installed or run in the ffparm python environment. If installed outside the environment, everything works just fine.

I suggest to continue working outside FFparam using psi4.

I have found a solution to that particular problem. I think it’s best to install psi4 first using the installation guide from the official site. Here are the commands I used:
bash -b -p $HOME/psi4conda

echo $’. $HOME/psi4conda/etc/profile.d/\nconda activate’ >> ~/.bashrc

echo “source $HOME/psi4conda/etc/profile.d/conda.csh\nconda activate” >> ~/.tcshrc
Exit the terminal, enter the psi4 pathway and run the command: psi4 --test
Now for the installation of ffparam, I used the following commands:
conda create -n ffpenv python=3.7

conda install -n ffpenv -c conda-forge freeglut libblas liblapack

conda install -n ffpenv -c rdkit rdkit=2019

conda install -n ffpenv -c anaconda paramiko pillow

conda install -n ffpenv -c psi4 psi4=1.3.2

conda install -n ffpenv -c omnia openmm

conda activate ffpenv

tar -xvf ffparam_v1.0.0.tar.gz

cd ffparam_v1.0.0

python install


I hope that helps.

Thank you!

As I assumed earlier the solution could have been to install psi4 first…
I’ll try to follow your steps (even if I am still able to work outside FFparm, but we want things to work as they shoud!).

Thanks again!

Dear Konstantina,
I tried to install psi4 before and followed the commands you’ve put but it still doesn’t work.
It’s ok, I will still use it externally, outside of ffparm.

Thank you!

Hello all,
I have downloaded the psi4 externally i e., not in ffpenv environment but while executing ffparam error: psi4 module was not found
How do I add psi4 to PYTHONPATH?

psi4 --psiapi lists the command to add psi4 to PYTHONPATH. But if you’re in a conda env where psi4 is in the conda list, adjusting PYTHONPATH shouldn’t be necessary.

Psi4 is in conda list.
I am trying to do QM calculation using ffparam, it shows ‘no module named psi4’ . If I use psi4 – psiapi and then export,. I’m getting importerror