Install issues with 1.9.1

I’m running under linux (Centos7).

I attempted to install psi4 1.9.1:

conda install -n psi4env_1-9-1 psi4 python=3.10 -c conda-forge

but got the error →

Solving environment: failed with initial frozen solve. Retrying with flexible solve.

PackagesNotFoundError: The following packages are not available from current channels:

  - psi4

So, I tried →

conda install -n psi4env_1-9-1 psi4 python=3.10 -c psi4

since this is the channel I have successfully used in the past. It did installed.

However, when I run psi4, I get the following error →

ERROR conda.cli.main_run:execute(41): `conda run /data/Apps/anaconda3/envs/psi4env/bin/psi4 -i water.inp -o out.txt` failed. (See above for error)
Valid config keys have changed in V2:
* 'allow_mutation' has been removed
Traceback (most recent call last):
  File "/data/Apps/anaconda3/envs/psi4env/bin/psi4", line 188, in <module>
    import psi4  # isort:skip
  File "/data/Apps/anaconda3/envs/psi4env/lib//python3.10/site-packages/psi4/", line 76, in <module>
    from .driver import endorsed_plugins
  File "/data/Apps/anaconda3/envs/psi4env/lib//python3.10/site-packages/psi4/driver/", line 42, in <module>
    from qcelemental import constants
  File "/data/Apps/anaconda3/envs/psi4env/lib//python3.10/site-packages/qcelemental/", line 6, in <module>
    from . import covalent_radii, models, molparse, molutil, periodic_table, physical_constants, util, vanderwaals_radii
  File "/data/Apps/anaconda3/envs/psi4env/lib//python3.10/site-packages/qcelemental/models/", line 10, in <module>
    from .align import AlignmentMill
  File "/data/Apps/anaconda3/envs/psi4env/lib//python3.10/site-packages/qcelemental/models/", line 6, in <module>
    from ..util import blockwise_contract, blockwise_expand
  File "/data/Apps/anaconda3/envs/psi4env/lib//python3.10/site-packages/qcelemental/util/", line 1, in <module>
    from .autodocs import auto_gen_docs_on_demand, get_base_docs
  File "/data/Apps/anaconda3/envs/psi4env/lib//python3.10/site-packages/qcelemental/util/", line 6, in <module>
    from pydantic import BaseModel, BaseSettings
  File "/data/Apps/anaconda3/envs/psi4env/lib//python3.10/site-packages/pydantic/", line 363, in __getattr__
    return _getattr_migration(attr_name)
  File "/data/Apps/anaconda3/envs/psi4env/lib//python3.10/site-packages/pydantic/", line 296, in wrapper
    raise PydanticImportError(
pydantic.errors.PydanticImportError: `BaseSettings` has been moved to the `pydantic-settings` package. See for more details.

For further information visit

Does anyone know why I am having issues?


See what I posted in Dependency error when installing psi4 in a fresh conda environment - #4 by kb1rd

I can’t copy it here.