Windows Anaconda nightly build failing on SAPT0 calculations

In reference to the 1.5 dev version of psi4 (installed as per my post here) psi4 is failing with the error:

PSIO_ERROR: unit = 193, errval = 8

when attempting to run SAPT0 calculations that have been successfully run in previous versions of psi4. In particular the calculation I am attempting was previously run with Psi4 1.3.2 on WSL.

The last few lines of the output file are as follows:

Ed Hohenstein
 6 June 2009

  Orbital Information

NSO        =       336
NMO        =       336
NRI        =      1116
NOCC A     =        37
NOCC B     =        13
FOCC A     =         9
FOCC B     =         3
NVIR A     =       299
NVIR B     =       323

The only error message in Anaconda prompt is PSIO_ERROR: unit = 193, errval = 8

Any ideas what is going wrong?

Tried changing scratch directory from default, no success.

As an update I had:

memory 4 GB

At the top of my input file. Removing this entirely, or setting to larger value (5, 6 or 40 GB) allows the calculation to proceed past the point above and does not result in an error message. Basically anything greater than 4 GB of memory works, or the default 500 MB…

Using the default 500 MB memory, the calculation appears to use ~ 500 MB. When setting a value larger than 4, the calculation tops out at around 1.1 GB.

Although the message you reported is the only error message explicitly written to stderr, there is a throw statement that would have been triggered and that is not mentioned in your report.

errval = 8 is Psi trying to close a file that’s already closed. Although the file opening and closing logic may depend on memory estimates, an error like this shouldn’t be directly dependent on memory allocation. unit = 193 says this is about the alpha-alpha block of density-fitted integrals.

That’s about as far as I can go without an input or output file that demonstrates the bug.

There is no other error or statement with this issue, not in the Anaconda prompt, nor in the output file.
using --verbose doesn’t give anything extra either.

(psi4environment) *****\working_directory\WORK>psi4 -n 10 -input test_input.dat -output test_output.dat
PSIO_ERROR: unit = 193, errval = 8

The following input file generates the error using a simple water dimer as an example.

memory 4 GB

molecule water_dimer {
     0 1
     O  -1.551007  -0.114520   0.000000
     H  -1.934259   0.762503   0.000000
     H  -0.599677   0.040712   0.000000
     0 1
     O   1.350625   0.111469   0.000000
     H   1.680398  -0.373741  -0.758561
     H   1.680398  -0.373741   0.758561

     units angstrom
     symmetry c1

set basis jun-cc-pvdz


Changing memory to the following values results in the same error:
2.2 GB
2.3 GB
2.4 GB
2.5 GB
3 GB
3.5 GB
4 GB
4.1 GB
4.2 GB

Any memory value less than or equal to 2.1 GB or greater than or equal to 4.3 GB does not result in an error.

That’s a much simpler input file than I expected.

When I try to reproduce this on my Mac, I can’t, but you already said this ran fine on WSL, so this isn’t very informative. Unfortunately, I don’t have a Windows machine, so the best I can do is transfer this to our issue tracker, where the SAPT developers will be more likely to see this.

Can you try again without -n 10? I’m curious if parallelization is involved.

Same behaviour with or without parallelisation.

I also have a much more complex SAPT calculation that I’m trying to run. No value of memory I have yet found will allow the calculation to complete. All 4, 8 25 & 40 GB all fail with the same error.

I have 1.4.1 & 1.5a1 running on a linux box which runs without error, so I will switch to that for the time being.