Use old Psi4 Version

Hello everyone, I’m trying to parametrize the ANP-PNP molecule using FFParam v1.2.0
Apparently, for this software to work correctly I have to use and old version of Psi4 and thats bringing me trouble.

I followed the installation instructions of FFParam, installing everything in a new conda environment.
By default the 1.9.1 version of psi4 was installed.
With FFParam I created the python file to be executed with Psi4, and worked correctly getting “Optimizer: Optimization complete!”.
But for the next step of the FFParam workflow I had errors extracting the data from the Psi4 output file.
Looking at the logs I found that the parser was looking for “Debye” variable, but according to the manuals: " The three components of the dipole [Debye] for the averaged coupled-pair functional level of theory. Deprecated in favor of [ACPF DIPOLE]".
So I started looking into the release notes of the different versions until I found this in v1.6: "Scalar Debye-based n-pole components QCVariables are retired, replaced by atomic-units arrays ".

So I tried installing in a new conda environment the previous release of Psi4, before deprecating the Debye variable.
conda create -n ffpenv openmm psi4=1.5+e9f4d6d -c conda-forge -c psi4

Now when I try to execute the same file that was working correctly with Psi4 v1.9.1 I get this error:
Traceback (most recent call last):
File “/home/leonardo/anaconda3/envs/ffpenv/lib/python3.9/site-packages/psi4/”, line 55, in
from . import core
ImportError: /home/leonardo/anaconda3/envs/ffpenv/lib/python3.9/site-packages/psi4/ undefined symbol: __svml_exp4_mask_e9

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/home/leonardo/Documents/ANP/ffparam/qmfiles/”, line 2, in
import psi4,os,importlib
File “/home/leonardo/anaconda3/envs/ffpenv/lib/python3.9/site-packages/psi4/”, line 60, in
raise ImportError(“{0}”.format(err))
ImportError: /home/leonardo/anaconda3/envs/ffpenv/lib/python3.9/site-packages/psi4/ undefined symbol: __svml_exp4_mask_e9

This is my conda version conda 24.5.0
This is my conda list

Name Version Build Channel

_libgcc_mutex 0.1 conda_forge conda-forge
_openmp_mutex 4.5 2_gnu conda-forge
ambit 0.5.1 hbe8a562_1 psi4
annotated-types 0.7.0 pyhd8ed1ab_0 conda-forge
blas 1.0 mkl conda-forge
bzip2 1.0.8 hd590300_5 conda-forge
ca-certificates 2024.6.2 hbcca054_0 conda-forge
chemps2 1.8.10 hbe8a562_0 psi4
colorama 0.4.6 pyhd8ed1ab_0 conda-forge
cudatoolkit 11.8.0 h4ba93d1_13 conda-forge
dftd3 3.2.1 h84218bc_2 psi4
dkh 1.2 hd59d2e7_0 conda-forge
exceptiongroup 1.2.0 pyhd8ed1ab_2 conda-forge
gau2grid 2.0.7 h0b41bf4_2 conda-forge
gcp 2.0.2 he991be0_2 psi4
gdma 2.2.6 h0e1e685_6 psi4
hdf5 1.10.6 h3ffc7dd_1
iniconfig 2.0.0 pyhd8ed1ab_0 conda-forge
intel-openmp 2021.4.0 h06a4308_3561
ld_impl_linux-64 2.40 hf3520f5_2 conda-forge
libblas 3.9.0 12_linux64_mkl conda-forge
libcblas 3.9.0 12_linux64_mkl conda-forge
libffi 3.4.2 h7f98852_5 conda-forge
libgcc-ng 13.2.0 h77fa898_7 conda-forge
libgfortran-ng 13.2.0 h69a702a_7 conda-forge
libgfortran5 13.2.0 hca663fb_7 conda-forge
libgomp 13.2.0 h77fa898_7 conda-forge
libint2 2.7.2 h2fe1556_1 psi4
liblapack 3.9.0 12_linux64_mkl conda-forge
libnsl 2.0.1 hd590300_0 conda-forge
libsqlite 3.45.3 h2797004_0 conda-forge
libstdcxx-ng 13.2.0 hc0a3c3a_7 conda-forge
libuuid 2.38.1 h0b41bf4_0 conda-forge
libxc 5.2.3 py39hea1df8f_2 conda-forge
libxcrypt 4.4.36 hd590300_1 conda-forge
libzlib 1.2.13 h4ab18f5_6 conda-forge
mkl 2021.4.0 h06a4308_640
mkl-service 2.4.0 py39h7e14d7c_0 conda-forge
ncurses 6.5 h59595ed_0 conda-forge
networkx 3.2.1 pyhd8ed1ab_0 conda-forge
numpy 1.26.4 py39h474f0d3_0 conda-forge
ocl-icd 2.3.2 hd590300_1 conda-forge
ocl-icd-system 1.0.0 1 conda-forge
openmm 8.1.1 py39hd38b9cb_1 conda-forge
openssl 3.3.1 h4ab18f5_0 conda-forge
packaging 24.0 pyhd8ed1ab_0 conda-forge
pcmsolver py39h6d17ec8_2 psi4
pint 0.23 pyhd8ed1ab_1 conda-forge
pip 24.0 pyhd8ed1ab_0 conda-forge
pluggy 1.5.0 pyhd8ed1ab_0 conda-forge
psi4 1.5+e9f4d6d py39hbf93d9d_0 psi4
psutil 5.9.8 py39hd1e30aa_0 conda-forge
py-cpuinfo 9.0.0 pyhd8ed1ab_0 conda-forge
pydantic 2.7.3 pyhd8ed1ab_0 conda-forge
pydantic-core 2.18.4 py39ha68c5e3_0 conda-forge
pytest 8.2.2 pyhd8ed1ab_0 conda-forge
python 3.9.19 h0755675_0_cpython conda-forge
python_abi 3.9 4_cp39 conda-forge
pyyaml 6.0.1 py39hd1e30aa_1 conda-forge
qcelemental 0.27.1 pyhd8ed1ab_0 conda-forge
qcengine 0.29.0 pyhd8ed1ab_0 conda-forge
readline 8.2 h8228510_1 conda-forge
scipy 1.13.1 py39haf93ffa_0 conda-forge
setuptools 70.0.0 pyhd8ed1ab_0 conda-forge
simint 0.7 h642920c_1 psi4
six 1.16.0 pyh6c4a22f_0 conda-forge
tk 8.6.13 noxft_h4845f30_101 conda-forge
tomli 2.0.1 pyhd8ed1ab_0 conda-forge
typing-extensions 4.12.2 hd8ed1ab_0 conda-forge
typing_extensions 4.12.2 pyha770c72_0 conda-forge
tzdata 2024a h0c530f3_0 conda-forge
wheel 0.43.0 pyhd8ed1ab_1 conda-forge
xz 5.2.6 h166bdaf_0 conda-forge
yaml 0.2.5 h7f98852_2 conda-forge
zlib 1.2.13 h4ab18f5_6 conda-forge

My OS is Ubuntu 22.04.4 LTS

Thank you for your time!

Yes, because of the complex history of the Libint2 transition and not post-editing pinnings, it can be very difficult to install old psi4 versions from conda. For older psi4, I’d recommend using one of the installers (akin to a miniconda installer with psi4 pre-installed), which has bundled a set of contemporary dependencies. You can go to a particular version’s download page (e.g., Install v1.6+ | Installs ) and select /installer//stable to get an address to curl. The full list of downloads is releases | . It’s a little awkward to have psi4 in a different conda env from all the rest of your toolchain, but I think adding the psi4conda/bin/psi4 to your PATH will do what you need.

1 Like