Unable to find a basis set for Iodine atom

As a beginner to quantum computation and also psi4, I tried to simple run in psi4 with iodine atom and get the error msg :
"Unable to find a basis set for atom 1 for key BASIS among:
Shell Entries: [u’I’] "

Searching on net, I tried with basis set sto-3g and it again gives the same msg. If I change the atom from iodine to different one, psi4 runs without any problem.

I will highly appreciate for your kind help.

Here is the input for psi4:

molecule I2 {
0 1
I -1.0559 0.0000 0.0000
I -1.4497 -1.0209 0.0000

basis {
assign sto-3g

thisenergy = optimize(‘scf’)

Hi @sahaskn,

This is strange – STO-3G is one of the only basis sets we do have for iodine – and I’ve just successfully run the exact input you provided. Just so we have a clearer picture of what might be causing the error:

  • Which basis set did you try the first time, before getting the same error with sto-3g?
  • What version of Psi4 are you running (should be printed in the header of the output file), and how was it installed (binary installer from the downloads page, a conda installation, or compiled from source)?

Basis sets aren’t entirely my wheelhouse; @loriab, any thoughts? Regardless of AM compiled with, the basis set should still be found, correct?

If it was compiled with too low AM, the error message would be a different one. If you ask for a 5-zeta or 6-zeta basis, it’s possible that it won’t find a valid fitting basis b/c our last-resort defaults are only quad-zeta. Neither of those should be relevant here.

My first suspect is what version of psi4 are you running? (psi4 --version)

Thanks for the reply. I apologise for late response as I was out of my place for a week.

It is Psi4 1.1.

I installed in ubuntu 16.04 system by psi4conda installer for python 2.7 version.

Before assigning sto-3g basis set, I used aug-cc-pcvqz as basis set.

The problem is now solved when I installed psi4 1.2 through conda. It now works with sto-3g and other basis sets that supports I.