Trouble compiling a plugin

Hey everybody,

My friend was trying to use the +aointegrals plugin to get the AO integrals. He got psi4 compiled, but he found that the plugin generates makefiles that are designed for Georgia Tech’s machines.

Here is what he said.

I think the basic documentation is pretty good, e.g. I didn’t have any trouble installing psi4 and running quick test calculations. I’m not as sure about the documentation on constructing new modules though. For instance, the documentation says the --new-plugin utility "can creat basic plugins…and tailor them to your compilation environment. But if I run psi4 --new-plugin myplugin +aointegrals, for instance, I am unable to compile the plugin, even though the Makefile says it shouldn’t need to be modified. The issue is that the Makefile includes paths such as CXX = /theoryfs2/common/software/intel2015/composer_xe_2015.3.187/bin/intel64/icpc, and others, which do not exist on my machine.

Long story short, it’s not clear to me how to actually compile a new plugin, since the produced Makefile won’t work, and I don’t think this is addressed in the documentation.

Hope this helps,


I do not observe this behavior with the current PSI4 in master. When I run “psi4 --new-plugin junk” it creates a Makefile with the same structure used to build PSI4 on my system.

That is strange. I just issued psi4 --new-plugin myplugin +aointegrals on my Mac and didn’t get any traces of GaTech configuration. Could you run which psi4 and echo $PSIDATADIR to make sure the right psi4 is being used. Is this a psi4 in something like objdir/bin/psi4 rather than an installed copy? try psi4 --new-plugin-makefile to generate just a new Makefile that’s suitable for transporting plugins between computers.