Setting psi4 scratch on Bridge2

Dear Sir
I am trying to set the scratch directory on Bridge2 but so far it is not working. So far, I have installed psi4 and test calculation worked fine. Then, I modified .bashrc file at my home directory and add this line at the end of the file.
export PSI_SCRATCH=/ocean/projects/MyAssigned#/MyName/scratch
In that location, I made scratch file folder.
Thank you very much.
Best wishes

I did not write error I got for this problem.
“Fatal Error: SCF::DF: Disk based algorithm requires 2 (A|B) fitting metrics and an (A|mn) chunk on core.
This is 2Q^2 + QNP doubles, where Q is the auxiliary basis size, N is the
primary basis size, and P is the maximum number of functions in a primary shell.
For this problem, that is 4586133840 bytes before taxes,6551619771 bytes after taxes.
Error occurred in file: /scratch/psilocaluser/conda-builds/psi4-multiout_1526277647828/work/psi4/src/psi4/libfock/ on line: 727
The most recent 5 function calls were:
I assumed I was not able to use my scratch directory assigned on /ocean/projects/MyAssigned#/MyName/scratch. So far, large calculation failed on Bridges-2 at PSC including the ones that completed successfully on my PC. Is this a software/environment issue?

The error you posted sounds like a memory issue rather than a disk issue.

For this problem, that is 4586133840 bytes before taxes,6551619771 bytes after taxes.

This suggests that you need ~6.5 GB memory for this calculation, and probably more for overhead. How much memory is allocated to your job on Bridges-2?

As an aside, the scratch directory you are using on ocean is for short-term storage of files for your project but is not directly linked to the node that your job runs on. Once you resolve this memory error, you will likely see better performance if you set the PSI_SCRATCH variable to the node’s local scratch dirctory in your batch script. On Bridges-2, this directory is set to the environment variable $LOCAL once the job starts.

After contacting the stuff at PSC, he told me the memory I requested 250GB of memory and was available for this process. It depends on number of core I requested. Then, I run the same job with different number of core and it crushes at nearly the same wall time (using 1core & 4 core). Both crash at near 3000 sec. Thank you very much for your help.

What version of Psi4 are you using? For all we know, you’re using a version that is years out of date.

Oh my goodness. That might have solved my problem. Thank you very much. :sweat_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.