Recommended gcc version


I am currently harassing our cluster administrator about a new gcc version installed for all users.
Would you recommend getting gcc5.4 for full C++11 support or is gcc.4.9.4 sufficient feature-wise?
Mostly with regards to psi4.


4.9 is all you need; that’s what we’ve been running locally. But you really do need at least 4.9, as 4.8.5 will start to compile but fail in libmints.

1 Like

Due to this issue, you can’t mix libraries that communicate through strings (e.g., psi4 and anything that uses a psi4 options object like plugins or chemps2) if they’ve been compiled with gcc on different sides of the 5.1 divide. If you’re building Psi4 and all its components in one grand cmake execution, this point is moot, but if you’re using pieces from conda packages provided in the psi4 channel (i.e., not python or numpy or such), you’ll want to be 5.1+ or face the dreaded “chartraits” link/runtime error.