psi4 failing with "symbol lookup error"


I’ve just performed an install of psi4 via ‘conda install psi4’ after installing Anaconda (from the Linux Anaconda-2.3.0-Linux installer from Continuum) and performing updates (conda update conda anaconda).

Kernel and (Red Hat) distribution of this particular box are as follows:

2.6.18-308.13.1.el5 #1 SMP Thu Jul 26 05:45:09 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Client release 5.8 (Tikanga)

I should mention that on other machines, this install / update process has gone fine and I am able to use PSI4 beautifully in those cases. But this particular workstation (RHEL / kernel version held at the rev. above for reasons of compatibility with other applications used internally here) is giving me fits. Upon attempting to run PSI4, I see the following:

psi4: symbol lookup error: psi4: undefined symbol: _ZNSs4_Rep20_S_empty_rep_storageE

Has anyone encountered this, and might anyone know of a fix or workaround? Thanks very much.

-Michael Bartberger
Molecular Engineering
Amgen, Inc.


conda install -f pyzmq

That’s what this site claims at least. If that doesn’t work can you post the full error message?

Could you also post the results of ldd --version? If it’s not >= 2.7, the binary just won’t work (elaborated in first bullet of

Dear All :

Hi Ryan-- thanks very much for the suggestion; I tried this first but this was not the cause.

Hi Lori-- Bingo-- this was exactly it (libc is only v. 2.5). My apologies for missing that on the install instructions (!) page where it is clearly called out. Upon connecting to a slightly newer vintage machine also having access to my home directory and existing anaconda/psi4 installation, everything worked perfectly.

Thanks once again.

Good, I’m glad you found a workaround. We, too, have clusters where the OS has been fixed for years and the binary can’t work. No problem about missing the warning bullet. Usually the Quick Install works so smoothly that the rest of the page is extraneous.