Psi4-1.0rc with max-am-eri=8


I am trying to install psi4-1.0rc with max-am-eri set to 8. Unfortunately, it is not possible because:

Number of VRR targets has exceeded the hardwired maximum MAX_NUM_TARGET_VRR_NODES
src/lib/libderiv/CMakeFiles/deriv.dir/build.make:61: recipe for target ‘src/lib/libderiv/libderiv.compiled’ failed

Is it possible to overcome this by just setting MAX_NUM_TARGET_VRR_NODES to a large enough value?


We only compile to 7 regularly and have not seen this before as far as I am aware. I assume these thresholds are more to ensure that the compilation does not kill your computer in memory/time. Id say bump it up and let us know what happens, it is unlikely to hurt anything.

I have done this successfully. In the file


I changed MAX_NUM_TARGET_VRR_NODES from 2000 to 4000 and was able to build the program and with it I reproduced a CCSD(T)/cc-pV8Z test case from the literature.

When I have some free time I want to build a version with max-am-eri=10 :slight_smile:

Thank you very much for the advice. After this change, the program could be built (gcc 4.8.5). The compilation took about 3 hours wall time using a single processor. All tests passed.

May I have a suggestion? In PSI 3.4, there were four options in the configure script:
–with-max-am-eri maximum AM in ERIs
–with-max-am-deriv1 maximum AM in ERI first derivatives
–with-max-am-deriv2 maximum AM in ERI second derivatives
–with-max-am-r12 maximum AM in R12 integrals

Those allowed the user to use large basis sets only in an energy calculation and offered more flexibility in building the program. Please consider including those options to PSI4.

1 Like

Could you give out a bit more details on how to recompile libint with the updated value of MAX_NUM_TARGET_VRR_NODES?

I’m also trying to compile Psi4 with max-am-eri set to 8 and getting the same error. I changed the value of the parameter in the source file and went: make clean. then make but it seems it had no effect. Any suggestions ?

I would suggest to start fresh from the tar file, make the change to MAX_NUM_TARGET_VRR_NODES, then configure and build. There is almost certainly a better way, but this worked for me.

I’m building the Fedora packages of libint with

%configure --enable-shared --disable-static
–with-libint-max-am=10 --with-libint-opt-am=6
–with-libderiv-max-am1=6 --with-libderiv-max-am2=5
–with-libr12-max-am=5 --with-libr12-opt-am=4

which I think compiles within a few hours. I changed the values with

-#define MAXNODE 10000
+#define MAXNODE 100000