Problem with running PSI4 with clang 4.0.0

Hey PSI4 community,

I am trying to get clang to work with openmp. I compiled a version of clang with openmp via the clang website. I can run simple programs with this new version of clang. I am using version 4.0.0 of clang with openmp enabled.

I am able to successfully compile psi4 with this version of clang. I run into problems when I try to run a test case.

If I run any test case, I get this error:

Could not find platform independent libraries
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to [:<exec_prefix>]
ImportError: No module named site

Setting PYTHONHOME does not make a difference. I still get the error ImportError: No module named site.

When I looked at the configure script, cmake correctly finds the right python installer. I can even import site if I run python separately.

Do any of you have an idea what went wrong?

Well, I have no idea what went wrong, but I managed to fix the problem.

I just had to change my PYTHONHOME=$HOME/anaconda2 from just pointing to the python binary. I was able to run psi4 before with no problem, but I did an update so something must of broke.

Anyway, everything is fine now.

You likely changed which python you’re compiling against. Linking against anaconda python on Mac often requires jumping through a couple extra hoops. Here’s the FAQ in case you need it again.