Problem regarding installing psi4 on MacOS


I wanted to install Psi4 on my MacBook Pro with version BigSur (11.6.5). I tried downloading through conda and source, and it seems like there is version conflict issue that makes these two paths unsuccessful. I then tried using the installer, while all previous steps worked well, I was stuck on the last “psi4 --test”, where my computer always complained “zsh: command not found: psi4”. Could anyone help me with this issue? Thanks!

Hmm, if you tried a conda install first, then probably you have an existing anaconda or miniconda installation, and that’s registered in your ~/.<something>rc (like ~/.bash_profile or ~/.zshrc) file. Then if you ran the psi4 installer, that behaves much like a miniconda installation, so probably it registered, too. I’d try which conda python psi4 and check out your rc files to figure out what’s active.


Problem resolved by referencing the psi4 executable. After I cd into the psi4conda directory and run exact same command but just with bin/psi4, everything worked out.

Hi Ioriab,

Thanks for your reply! I tried which conda python psi4 though it still replies psi4 not found. Fortunately I’ve resolved the problem by referencing the executable.

1 Like