MP2 natural orbitals for MCSCF

Dear all,

Is it possible to feed MP2 NOs into an MCSCF calculation (CASSCF specifically)? MP2 NOs seem to be better suited for constructing an active space than MOs from an SCF calculation.

I could not find any commands for that in the DETCI module documentation, but maybe there is a workaround?


I am away from my computer, but there should be a example detailing how to do this. Look for a mcscf-no-* or casscf-no-* title

Thanks for the reply!

Among the samples ( I looked here: I could not find an example that shows this.

Maybe you can send me the link to the example if you have time?

Also, I know that you can pass a reference wavefunction to the energy(…) command but the MP2 wavefunction is the same as SCF wavefunction, so this doesn’t help.

At a laptop now, this looks like a problem on our end. You can set mcscf_guess mp2 which will give you a MP2 natural orbital guess. The energy command is not a good place for densities as it is often much more costly to compute a methods density than energy. You can check out the rasci-ne for an example on passing wavefunction densities.

Hi, sadly it’s still not working for me. If I run this script:

molecule {
H 1 r
H 1 r 2 a
symmetry c1
r = 1.00
a = 103.1

set {
    basis            cc-pvdz
    nat_orbs         true
    d_convergence    9

set detci {
    restricted_docc  [1]
    active           [6]
    restricted_uocc  [17]
    mcscf_diis_start 20
    mcscf_maxiter    100

set mcscf_guess  scf
set mcscf_guess  mp2

I get two times exactly the same calculation. When the MP2-wavefunction is passed to the casscf-calculation with

mp2_e, mp2_wfn = properties("MP2", return_wfn=True)
energy('casscf', ref_wfn=mp2_wfn)

Psi4 aborts with the message in the terminal forrtl: severe (71): integer divide by zero. The output-file stops before the first MCSCF-Iteration has finished with no error messages. Is it possible for you to provide me with an example file for a calculation that uses MP2 natural orbitals for a CASSCF calculation?