Issue after psi4 compilation psi4 1.3 dev

I was trying to compile from source the current psi4 git source (master). I was able to compile without reported error using the following (on a Mac):

cmake -H. -Bobjdir \
        -DCMAKE_INSTALL_PREFIX="/Users/Ordinary/bin/psi4" \
        -DMAX_AM_ERI=6 \
        -DENABLE_simint=ON \
        -DENABLE_gdma=ON \

However, when I ran ctest, all 446 tests failed. I tried to run ./psi4 --test in the objdir/stage/bin/ folder but that returned a ModuleNotFoundError: No module named ‘pint’.

Could you please guide me through the compilation?


Just install the pint Python module. You won’t even need to recompile! pip install pint should do it.

For the record, we recommend users spare themselves the pain of compiling by using the conda version of the nightly build.

You can keep asking if you’re still having problems, but if this answers the question, you can mark my post as having answered it by clicking on the checkmark in the bottom-right of my post.

That actually does the trick for me. I usually use the release version. However, I wanted to take advantage of the great speed increase in 1.3a2 with DFT caching, hence the build-it-myself situation as the Anaconda cloud doesn’t have the conda binary for mac for this version yet. Thanks for the help!

Let us know your experience with the new DFT caching, we are very interested to hear how this helps out in the wild.

Preliminarily, I’ve seen speed improvement on a 60-atom geometry optimization using b3lyp/6-31g* from 25 hrs (psi4 1.2.1) to 16hrs (1.3a2) on my lab computer (4 cores). Sometimes I got lucky and even got to an 8-hr run. This is the main reason I wanted to build the alpha 2 on my mac.

Fantastic, that is great to hear!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.