Installing PSI4 on a cluster with obsolete glibc

So recently, I tired to install the 1.1 binary conda package on a compute cluster I have access to, but unfortunately the cluster is running an obsolete software environment, and I am pretty sure glibc is too old for PSI4.

installing: python-3.6.1-2 …
Python 3.6.1 :: Continuum Analytics, Inc.
installing: conda-env-2.6.0-0 …
(plugins omitted for brevity)
installing: cffi-1.10.0-py36_0 …
installing: gcc-5-5.2.0-1 …
/home/gytibor0000/psi4conda/bin/gcc: /lib64/ version GLIBC_2.11' not found (required by /home/gytibor0000/psi4conda/bin/gcc) /home/gytibor0000/psi4conda/bin/gcc: /lib64/ versionGLIBC_2.11’ not found (required by /home/gytibor0000/psi4conda/bin/gcc)
Installation failed: gcc is not able to compile a simple ‘Hello, World’ program.
Error: post-link failed for: gcc-5-5.2.0-1

Is there any relatively easy way around this? No, the admins will not upgrade the system.

Hmm, the psi4 conda packages are built to work on glibc 2.7 (2.7 < 2.11 when comparing glibc versions) or newer. Check ldd --version to confirm your glibc version. If its just bin/gcc that’s complaining, it’s not a used part. The building of the gcc/libgcc_s that ships with psi, I don’t have control over, and I see now that gcc does depend on 2.11. The part of that package psi needs, though, is lib/ and that only needs 2.5.2. So, find out your glibc version, and it could be that if you can it to install, it’ll be fine even with the gcc error.

According to ldd --version the cluster has glibc 2.5, so its close, but no cigar.

Yes, conda binary is right out, I regret. You can check your g++ version (the one native to the cluster, not the one that ships with psi4). If that’s >=4.9, I can probably help you compile psi, but that’s the last resort at this point.

Nope, that’s a no go as well, the cluster has GCC 4.7.2, and ICC 2013 SP1.
Cmake is also ancient (

Well, CMake’s easy to update. But unless you can finagle gcc 4.9 onto the cluster (compile it?), I think it’s no good unless you wanted to go back to a 1.0 or older version. Since dropping Boost, we need gcc 4.9 for C++ regex. There’s plans to get around that dependency, but they’re not imminent.