Installation + enable gdma


I am trying to install Psi4 using conda as:

conda install gdma -c psi4 -d --ENABLE_gdma

In the manual, you mention that an error is expected without enabling GDMA so I get:

Traceback (most recent call last):
File “/usr/bin/psi4”, line 248, in
File “”, line 32, in
File “/usr/lib/psi4/driver/”, line 1756, in gdma
core.run_gdma(wfn, commands)

Fatal Error: GDMA not enabled. Recompile with -DENABLE_gdma.
Error occurred in file: /build/psi4-XGp1km/psi4-1.1/psi4/src/ on line: 468

Following a long list of the recent function calls.


Any advice, what should I do?

Thank you in advance.


I think psi4 installed with ubuntu or debian repository didn’t be enabled gdma feature, so how about install psi4 with “conda install psi4 psi4-rt -c psi4”?

Ok, we need to get clear how you’re acquiring Psi4 because the command you posted is mixing conda and cmake arguments.

  • Would you be happy with a completely conda installation? conda install psi4 -c psi4 comes with gdma already installed and compiled in. psi4 --test should show “PASSED” for the gdma test.
  • Is the Ubuntu or Debian package repository at all involved? I suspect @Pistack1234 is right about not enabling gdma by default.
  • If you want to build Psi4 from source, you easiest thing is to just cmake ... -DENABLE_gdma=ON. If you’re using psi4-dev pkg with psi4-path-advisor command to build Psi4 from source with dependencies from conda, the default command will enable gdma.