Installation AM8 - Error finding Libint2 - CMake libdl no match DL

Hi I am trying to compile and install a PSI4 version in which the AM Max is set to 8. I performed the following steps as suggested in Issues · psi4/psi4 · GitHub

conda create -n p4dev psi4-dev python=3.8 -c psi4/label/dev -y
conda activate p4dev
conda install libint am8 -c psi4/label/dev -y
git clone && cd psi4
`psi4-path-advisor --gcc` -DMAX_AM_ERI=8 -DENABLE_simint=OFF -DCMAKE_INSTALL_PREFIX=${CONDA_PREFIX} -DLibint_DIR=/home/matthak/.conda/envs/p4dev/share/cmake/Libint -DPYMOD_INSTALL_LIBDIR=/python3.8/site-packages
cd objdir && make install -j`getconf _NPROCESSORS_ONLN`

The error I receive is always after downloading (succesful) and installing (succesful) Libint2:

CMake Error at CMakeLists.txt:167 (find_package):
  Found package configuration file:


  but it set Libint2_FOUND to FALSE so package "Libint2" is considered to be

Which I think is the direct result of:

CMake Warning (dev) at /home/matthak/.conda/envs/p4dev/share/cmake-3.24/Modules/FindPackageHandleStandardArgs.cmake:438 (message):
  The package name passed to `find_package_handle_standard_args` (libdl) does
  not match the name of the calling package (DL).  This can lead to problems
  in calling code that expects `find_package` result variables (e.g.,
  `_FOUND`) to follow a certain pattern.

I am no CMake expert at all so solving this problem myself is unfortunately not (yet) within my skillset. I tried changing the CMake arguments to see if that would solve the problem, but I kept on receiving this error.

Could someone maybe help me with this problem?

Those instructions (the conda install libint am8) would only get you a version of libint that Psi4 doesn’t use anymore. Instead the buildsystem is trying to build a fresh version from source. That will take many hours, and I don’t recommend it. I hope to supply Psi4 with a bigger AM ints library soon. For this moment, v1.4 from conda comes with AM8 on Linux.

Thank you for the help, it works now!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.