Fixed dihedral optimization error

Hello all,

I am having a problem performing a constraint optimization where I am constraining a heavy atom torsion angle. The calculations run to completion for when I constrain my torsion (atoms 1, at 30, 60, 90, 120, 150 and 180 degrees, but not for 0 degrees. At 0 degree I obtain the following error message:

Previous internal coordinate definitions found.
The INTCO_EXCEPTion handler:
Format of dihedral entry is "D atom_1 atom_2 atom_3 atom_4 (eq_val)"
Dynamic level is 0.
exc.g_really_quit() is 0.

The job does produce a filename.intco, which contains the following line:
D 1 5 18 17 0.00000

Here is my input for 0 degrees
memory 30 Gb

molecule molecule_01 {
0 1
C -0.27400 -3.10800 -0.68800
H -0.72800 -2.72800 -1.60200
H -0.58500 -4.14400 -0.55600
H 0.80700 -3.08900 -0.82200
C -0.67900 -2.24600 0.50900
H -0.23900 -2.65400 1.42000
H -1.76100 -2.29000 0.64000
C 0.88500 -1.09100 -1.97600
H 1.91800 -1.43300 -1.90000
H 0.80600 -0.47200 -2.86900
H 0.25600 -1.96700 -2.12000
C 0.08200 2.67300 1.79600
H -0.44500 3.46700 1.26700
H 1.08500 3.03200 2.02200
H -0.43300 2.49800 2.73800
S 0.85500 1.31900 -0.54600
C 0.45700 -0.34700 -0.75200
C -0.23500 -0.82300 0.34700
C -0.42100 0.17900 1.33500
H -0.94600 0.01000 2.26500
C 0.11100 1.40500 1.00500
set globals {
reference rhf
g_convergence qchem
basis cc-pvtz
freeze_core true

set optking {
fixed_dihedral = ("
1 5 18 17 30.0


I have tried to solve this in a variety of ways, but for the life of me I can not get this to run. Any suggestions would be appreciated.


Hi again,

After another trial, I was able to get the 0 degree running by using an optimized structure from GAMESS (using the same input structure as I posted above) as my Psi4 input. So the error seems to be due to the quality of the input structure.


Here is an update from yesterday’s post.

I was wrong yesterday (second post) in saying that I was able to get Psi4 to run using a structure optimized from GAMESS (HF/6-31G(d) ) - I had the dihedral constrained to 1 degree.

Interestingly, if I take this optimized structure and resubmit it as a new calculation, with the angle constrained at 1 degree, I run into the same error as I originally posted. Running the calculation with constraint angle at 0 degrees also gives the same error.

So, I am still puzzled by this behavior and would appreciate any feedback.


Hmm this is a little strange. Might be a question for @Rollin_King.

As one might have guessed, this error is indeed due to a little I/O bug not allowing the float specifying the equilibrium value to be exactly zero. It is apparent even with a little test on HOOH. I’ve fixed the error and will commit the fix ASAP. Thanks for your clear presentation of the problem. (Although I never tested this, I presume setting the value to something small like 0.00001 would work with the current code.)

Hello Rollin and all,

I’ve been able to get back and revisit this problem. Today, I have updated my Linux psi4 code to Psi4 1.0.54 via “conda update psi4” line command. When I tested this, I am still getting the same error as before.

I also tried setting the torsion angle value to 0.00001. This continues to give the same error.


Just conda update psi4 wouldn’t get you to a version with Rollin’s fix in it. Will post procedure once today’s obstacle overcome.

Ok, there’s a testable conda version ready. Instructions at . If that’s not comprehensive enough and doesn’t help, write back.

Hello - Just wanted to finalize this topic.

I’m confirming that updating the code (to version Psi4 1.1a2.dev170) with the changes implemented by Rollin solved the problem. Thanks for the work and feedback!