Error with optimising enzyme with metal ion

I installed PSI4 in Linux machine using the commands given in [Install v1.8+ | Installs] . Then scratch file location was set up using the command

export PSI_SCRATCH=/gave/the/path/to/existing/writable/disk/for/scratch/files

Since I have less idea in creating Psi4 input file, I created the input file using Avagadro software by uploading my pdb file. Then in the same terminal I gave the scratch file location I gave the command


But I get an error message

! !
! Fatal Error: BasisSet contains ECP shells but libecpint addon not enabled. Re- !
! compile with -D ENABLE_ecpint=ON. !
! Error occurred in file: /home/conda/feedstock_root/build_artifacts/psi4_16838157 !
! 05191/work/psi4/src/ on line: 145 !
! The most recent 5 function calls were: !
! psi::PsiException::PsiException(std::__cxx11::basic_string<char, !
! std::char_traits, std::allocator >, char const*, int) !
The input file created contained,

molecule {
7 1
coordinates of the atoms of the residues and the metal ion
set basis LanL2DZ
set reference uhf

Then following the answers given for the question , tried to install libecpint package . But still the same error is given.
Please help me to solve this.
Thank you.

Sorry to hear you ran into another issue.

The psi4 build system is currently in the middle of a switch to building on conda-forge and it looks like libecpint hasn’t quite made it into a packaged psi4 release on conda-forge. Libecpint is a build-time dependency, which is why just installing it into your environment isn’t working. Your options right now are:

  • install psi4 1.7 (libecpint will be enabled by default)
  • compile psi4 1.8 from source with -D ENABLE_ecpint=ON

@philipmnel Thank you for the support. I installed psi4 1.7 and started a run.
But does it take a long time to write out put file? Though my program is running, the output file size is not changing. Means after around one hour nothing new is written in the output file. Is it due to any mistake in the process?