Error while loading shared libraries /bin/../lib/ ELF file OS ABI invalid

Thank you for answering me this question.
I had installed the pre-compiled binary for Linux (, and there were no problems during the installation process.However, when I run psi4, the error comes. How to solve this problem? Thanks!

What’s ldd --version? And is that the whole error?

I use the ldd (GNU libc) 2.9 version, and it is the whole error.

Again, please, what’s:

  • ldd --version
  • psi4 --version
  • and if the previous doesn’t work, psi4-config --all

I tried psi4-config --all, and this error also exist.

You still haven’t reported ldd --version. And psi4-config is a python script, so if it’s reporting ELF errors, your environment has considerable problems way beyond psi4.

ldd --version
ldd (GNU libc) 2.9

psi --version
Error while loading shared libraries /bin/…/lib/ ELF file OS ABI invalid

psi4-config --all
no error

Ok, nothing wrong with 2.9 (anything over 2.7 should work). What’s the actual output of psi4-config --all?

Almost certainly it’s a good idea to update to a 1.1rc1-era psi4 rather than a (presumably) 1.0-era. Instructions below. You might face the same error at the end, but least it’ll be a more modern Psi.

Download one of the six installers (Linux/Mac; Py27, 35, 36; presently at bash it. Follow the prompts and do make the adjustments to PATH and PSI_SCRATCH that it suggests at the end. Test with psi4 --test. Done.

Thank you very much!
I will try it soon.