Error for sapt dmp2 calculation

Dear friends,

I tried to test a simple dmp2 corrected sapt calculation. However, it always failed. Other types of sapt (without dmp2) can finish nicely. Can anyone give me some hint what was wrong in my case? Thank you very much.


water2-psi4-sapt-gold.dat (473 Bytes) water2-psi4-sapt-gold-output.txt (31.3 KB)


The error points to a read/write issue of a file. You need about 0.5GiB or so scratch space.
Could you confirm disk space or access (eg a slow network drive) are not an issue?

I could not reproduce the error with my psi4 installation.

HI hokru,

Thank you very much for the help. I definitely have enough scratch space (more than 500GB) and it is a local hdd. I tried to monitor the scratch folder and did observe some files with “monomer” “dimer” in their file names appeared in the scratch folder when calculations began, and disappeared when the calculation stopped. Can you post your output from my input so I can take a look?
Thank you very much.

here is my output: forum.out.txt (50.3 KB)

Thank you for the output file. Could not find what was wrong in my side. Will leave it for future.
Thanks again.

Accidentally found out what is the problem: I usually run psi4 like this: “psi4 -i $task.dat -o $task.out -p $task”. It turns out it is “-p $task” causing the problem. No idea why though. And it only affects dmp2 corrected sapt. All other sapt calculations are fine with the "-p " option.

Yes, you are right. I can confirm the issue. From a quick poke it seems the file for the MP2 fitting metric does not get the custom prefix (the -p option)

open an issue here: