Binary testers needed

@dgasmith, @kannon92, @crawdad, @avcopan, @Sahan, @francesco, @andysim, @jturney, @jgonthier, @ryanmrichard, @sherrill, @robertodr, @Rollin_King, @bennybp, @bozkaya, @deprince

New Linux build and altered distribution system ready. Please try it out and report back answers to the simple questions below. If I get enough successful responses on a variety of Linux systems in the next 24 hours, I’ll call 1.0.

Download from the Linux column of here. If that fails, try curl -O "". If that fails, try curl -O "" --keepalive-time 2.

  • (1) Did any of the three download routes ([a] button, [b] curl, [c] curl w/keepalive) fail?

  • (2) What Linux flavor (e.g., RHEL, Ubuntu)?

  • (3) What glibc version (run ldd --version)?

  • (4) Did the installer end with the below?

	Psi4 + DFTD3 executable...........................................PASSED
	Psi4 + CheMPS2 library............................................PASSED
	Psi4 + PCMSolver library..........................................PASSED
	Psi4 + V2RDM_CASSCF plugin........................................PASSED

	Psi4 library......................................................PASSED
  • (5) Once psi4conda is added to your path, what is ldd -v $(which psi4)?

  • (6) More detailed download instructions will be available. But even without, was anything actually confusing?

  • (7-optional) conda install gcc, then checkout a plugin template and make sure make and psi4 run the sample input ok.

  • Clicking on Linux button works for me, but took a very long time (like a minute) and I had no indication it was doing anything for the majority of that time (Chrome’s loading indicator spun for like a second).
  • I’m on Ubuntu 14
  • Ubuntu EGLIBC 2.19-0ubuntu6.6
  • no, it couldn’t find the data dir =>  (0x00007ff0dff3000) => /lib/x86_64-linux-gnu/ (0x00007fee0cbc7000) => /lib/x86_64-linux-gnu/ (0x00007fee0c8c1000) => /lib/x86_64-linux-gnu/ (0x00007fee0c6b8000) => /lib/x86_64-linux-gnu/ (0x00007fee0c4b4000) => /home/ryan/psi4conda/bin/./../lib/ (0x00007fee0c0cd000) => /lib/x86_64-linux-gnu/ (0x00007fee0beae000) => /lib/x86_64-linux-gnu/ (0x00007fee0bae9000) => /home/ryan/psi4conda/bin/./../lib/ (0x00007fee0aa0a000) => /home/ryan/psi4conda/bin/./../lib/ (0x00007fee09d3b000) => /home/ryan/psi4conda/bin/./../lib/ (0x00007fee09862000) => /home/ryan/psi4conda/bin/./../lib/ (0x00007fee09643000) => /home/ryan/psi4conda/bin/./../lib/ (0x00007fee0942c000)
/lib64/ (0x00007fee0cdee000) => /home/ryan/psi4conda/bin/./../lib/./ (0x00007fee09216000) => /home/ryan/psi4conda/bin/./../lib/./ (0x00007fee08ecb000)
Version information:
./psi4: (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.3) => /lib64/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/ (GLIBC_2.4) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.4) => /lib/x86_64-linux-gnu/ (GLIBC_2.3) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/lib/x86_64-linux-gnu/ (GLIBC_PRIVATE) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/lib/x86_64-linux-gnu/ (GLIBC_PRIVATE) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/lib/x86_64-linux-gnu/ (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/ (GLIBC_PRIVATE) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.14) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/ (GLIBC_PRIVATE) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/lib/x86_64-linux-gnu/ (GLIBC_PRIVATE) => /lib64/ (GLIBC_PRIVATE) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/home/ryan/psi4conda/bin/./../lib/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.3) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib64/ (GLIBC_2.3) => /lib64/ (GLIBC_PRIVATE) => /lib64/ (GLIBC_2.14) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/ (GLIBC_PRIVATE) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/lib/x86_64-linux-gnu/ (GLIBC_2.3) => /lib64/ (GLIBC_PRIVATE) => /lib64/
/home/ryan/psi4conda/bin/./../lib/ (GLIBC_2.3) => /lib64/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GCC_4.2.0) => /home/ryan/psi4conda/bin/./../lib/./ (GCC_3.3) => /home/ryan/psi4conda/bin/./../lib/./ (GCC_3.0) => /home/ryan/psi4conda/bin/./../lib/./ (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (VERSION) => /home/ryan/psi4conda/bin/./../lib/./ (GLIBC_2.4) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.4) => /lib/x86_64-linux-gnu/ (GLIBC_2.3) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/home/ryan/psi4conda/bin/./../lib/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.3) => /lib64/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/ (GLIBC_2.4) => /lib/x86_64-linux-gnu/ (GLIBC_2.3) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.4) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/home/ryan/psi4conda/bin/./../lib/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.3) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/home/ryan/psi4conda/bin/./../lib/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/home/ryan/psi4conda/bin/./../lib/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/home/ryan/psi4conda/bin/./../lib/./ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
/home/ryan/psi4conda/bin/./../lib/./ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.3) => /lib64/ (GLIBC_2.4) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.4) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/ (GLIBC_2.3.2) => /lib/x86_64-linux-gnu/ (GLIBC_2.2.5) => /lib/x86_64-linux-gnu/
  • I think your directions are fine, with the exception that a total noob might not know to make the script executable (or call it with the bash command).

I’d also be happy to test a new 1.0rc2 tarball/tag by packaging it up for Debian/Ubuntu if you’d make one. There’s been quite a few changes since 1.0rc.

(1) From command line so no a), b) timed out, c) worked fine.
(2) RHEL, as a note I had to chmod the install script.
(3) ldd (GNU libc) 2.17
(4) Yup

(5) => (0x00007ffe2c1f3000) => /lib64/ (0x00007fe4a308b000) => /lib64/ (0x00007fe4a2d89000) => /lib64/ (0x00007fe4a2b81000) => /lib64/ (0x00007fe4a297c000) => /theoryfs2/ds/dsmith/psi4conda/bin/…/lib/ (0x00007fe4a2595000) => /lib64/ (0x00007fe4a2379000) => /lib64/ (0x00007fe4a1fb7000) => /theoryfs2/ds/dsmith/psi4conda/bin/…/lib/ (0x00007fe4a0ed8000) => /theoryfs2/ds/dsmith/psi4conda/bin/…/lib/ (0x00007fe4a020a000) => /theoryfs2/ds/dsmith/psi4conda/bin/…/lib/ (0x00007fe49fd30000) => /theoryfs2/ds/dsmith/psi4conda/bin/…/lib/ (0x00007fe49fb11000) => /theoryfs2/ds/dsmith/psi4conda/bin/…/lib/ (0x00007fe49f8fb000)
/lib64/ (0x00007fe4a32b6000) => /theoryfs2/ds/dsmith/psi4conda/bin/…/lib/./ (0x00007fe49f6e4000) => /theoryfs2/ds/dsmith/psi4conda/bin/…/lib/./ (0x00007fe49f39a000)

(6) Just the chmod thing might have been confusing for some users.

  1. Clicking on the button worked, but the download took quite a long time and I could not execute the script:
    ERROR: size of should be 280582635 bytes
    curl didn’t work either giving the following error
    curl: (18) transfer closed with 228880096 bytes remaining to read
  2. I am on Ubuntu 15.10
  3. glibc version 2.21 (Ubuntu GLIBC 2.21-0ubuntu4.3)

@robertodr Try curl with the timeout flag. Looks like conda is hard pressed to serve up 250MB.

Seconding the please try out the --keepalive-time 2 curl variant, @robertodr. It’s not conda that’s hard-pressed to serve up the 280mb, as this is a download from, it’s just large in general, and the keepalive was the way I found around it. Would be good to know if keepalive works for all.

@ryanmrichard, we decided your problem was an interfering PSIDATADIR already set. You’ll still have to squash this in a real working environment, but I uploaded a new installer that will do the install tests correctly even if set. Thanks for uncovering this!

Thanks. I was just going to make the 1.0rc2 tag and found that Psi4+CheMPS2 is broken again. Will mint it as soon as I can.

@loriab @dgasmith I had actually tried both curl variants. No success today either…

OK, I can download successfully on the Tromsø cluster:
2. CentOS release 6.7
3. glibc version 2.12
4. CheMPS2 testing failed with this:

Fatal Error: DMRG_CASPT2 is not a valid option.
Error occurred in file: /scratch/cdsgroup/conda-builds/work/src/lib/liboptions/liboptions.h on line: 59

I obtained no output attesting that either PCMSolver or v2RDM_CASSCF were tested. Though running by hand one of the PCM tests showed that everything works just fine.
5. Despite the location of psi4conda being added to PATH ldd -v psi4 returns ldd: ./psi4: No such file or directory
But which psi4 points to the correct executable…
6. Installation instructions are clear enough, IMHO
7. Everything in this step worked like a charm :smile:

Testing email replies.

Thanks @robertodr,

  • So did the download never work on the one machine and the Tromso cluster was a different, successful attempt? That’s sad that keepalive wasn’t a universal fix. Did you try other values than 2?
  • On (5), it has to be ldd -v $(which psi4) if you don’t navigate. I fixed the directions now.
  • On (4), I think I’ll separate out the tests, so if one doesn’t work, you’ll still see results from the others. I’m still trying to figure out why DMRG_CASPT2 was invalid.

Ok, @mbanck, Psi4+CheMPS2 is healed, and 1.0rc2 tag is pushed.

I had to fiddle with our versioning to keep it monotonic with this tag– basically, this tag will compute to 1.0rc200 and subsequent commits will increment.

If I do push 1.0 proper in the next day or two, is that going to cause havoc with your workflow?

I just uploaded a new installer, @robertodr, so please give it a try if you have a chance, along with the updated ldd line. I don’t understand the caspt2 error, so would like to see it resolved.

Everyone, you can start criticizing , which is an updated downloads page.

I’ve got responses from wholly successful me on gatech pace, partially successful Ryan, partially successful Roberto, and wholly successful Sahan. Any other Linux clusters out there?

  • No it never worked, but I was trying it during a conference and it might have been a problem with the Internet connection. I tried values other than 2 and they didn’t work.

Everything works wonderfully with the new installer! I managed to download from the webpage, so I guess there really was some issue with the internet connection at the conference.
2. I am on Ubuntu 15.10
3. glibc version 2.21 (Ubuntu GLIBC 2.21-0ubuntu4.3)
4. All tests passed.
5. ldd -v $(which psi4) returns: =>  (0x00007ffc287d9000) => /lib/x86_64-linux-gnu/ (0x00007f930e6f2000) => /lib/x86_64-linux-gnu/ (0x00007f930e3e9000) => /lib/x86_64-linux-gnu/ (0x00007f930e1e1000) => /lib/x86_64-linux-gnu/ (0x00007f930dfdd000) => /home/roberto/Software/psi4conda/bin/../lib/ (0x00007f930dbe2000) => /lib/x86_64-linux-gnu/ (0x00007f930d9c4000) => /lib/x86_64-linux-gnu/ (0x00007f930d5fa000) => /home/roberto/Software/psi4conda/bin/../lib/ (0x00007f930c51a000) => /home/roberto/Software/psi4conda/bin/../lib/ (0x00007f930b84c000) => /home/roberto/Software/psi4conda/bin/../lib/ (0x00007f930b373000) => /home/roberto/Software/psi4conda/bin/../lib/ (0x00007f930b153000) => /home/roberto/Software/psi4conda/bin/../lib/ (0x00007f930af3d000)
/lib64/ (0x0000562078b16000) => /home/roberto/Software/psi4conda/bin/../lib/./ (0x00007f930ad26000) => /home/roberto/Software/psi4conda/bin/../lib/./ (0x00007f930a9dc000)
  1. Creating a plugin template works.

Great! thanks, @robertodr