Report problems with 1.1 installers

I’m trying to install Psi4 on a Mac (10.12.2, 2.3 GHz Intel Core i7). The installer seems to run fine with no errors, but I am getting the “Illegal Instruction: 4” error when I try to run the binary. I’m not quite sure where to begin on trying to resolve this; any tips would be greatly appreciated!

I’m working on the “Illegal Instruction: 4” error.

In other news, if you’re running the installer on a non-up-to-date Windows and get the following at runtime

OMP: Error #100: Fatal system error detected.
OMP: System error #22: Invalid argument
forrtl: error (76): Abort trap signal

the solution is to

export KMP_AFFINITY=disabled

I have the same problem. Both the psi4conda version, the anaconda version (“conda install psi4 psi4=1.1+…”), and source build on macOS Sierra. MacBook Pro mid 2012, 2.6 GHz Intel Core i7.

I’m working on the Illegal Instruction 4 problem. I’m surprised you’re getting it on a build from source, though. You’re truly building everything from source, including integrals?

Looking at the output from cmake, I see that it finds libint.dy and some other libraries in my anaconda3 installation. So maybe it is not all built from scratch, and maybe the culprit is here?

I have now upgraded to the last xcode version, I am trying to remove the libraries in anaconda3, and recompiling. I will report by editing this post.

EDIT: So I managed to suscessfully build Psi4, and I think I have found the culprit for the “Illegal Instruction: 4” error in my case. By editing CMakeLists.txt, I tried first to exclude Libint detection, but the error persisted. However, when I excluded Libxc, it worked! Libxc was originally detected in the anaconda3 installation.

Psi4 now runs and successfully does calculations for me.

By the way, the CMakeLists.txt has a typo. Line 46 reads
# For any ${AddOn} of: ambit, CheMPS2, dkh, libefp, erd, gdma, Libint, PCMSolver, pybind11, simint, LibXC

but should probably read
# For any ${AddOn} of: ambit, CheMPS2, dkh, libefp, erd, gdma, Libint, PCMSolver, pybind11, simint, Libxc

EDIT 2: For what it’s worth:
$ conda list | grep libxc
libxc 3.0.0 3 psi4

I’m getting illegal hardware instruction on Mac OS 10.9.5, a mid-2012 MBA with a 2.0 GHz i7-3667U.

I haven’t tried a source build, just the psi4conda installers.

Other note: there’s no number 4 present.

Yes, older hardware is susceptible. A pure-source build will be ok (you can’t even use conda libint.dylib). We’re debugging it, but it’s long distance between the person who does the conda builds and the person with a susceptible computer, so going slowly. Thanks for the report.

Ok, illegal instruction 4 victims, try out the following.

conda create -n p4env psi4 sse41 python=3.6 -c psi4/label/dev -c psi4
source activate p4env
python -c "import psi4; psi4.test()"

Only py36 at the moment. No Psi4conda installer at the moment. Please report back success or failure. If the latter, then also report result of sysctl machdep.cpu | grep features.

Success! This works on Mac OS 10.12.5 with late 2012 MBP and 2.9 GHz Intel Core i7.

Yay, thanks Brandon. Try it on the Mac Pro if you get a chance.

Success again! This fix also works on Mac OS 10.12.5 with a late 2013 Mac Pro (3.5 GHz Intel Xeon E5).

Ah, good. That means that every operating Mac we know is at least SSE4.1. Thanks for checking, @BrandonB.

Success! This fix worked on my Mid 2012 2.3 GHz i7 Macbook Pro running 10.12.2

great, @mmavros, thanks for reporting. If you want to try an installer, do one of the “old hardware” here (

I am trying to build psi4 on mac 10.12.6 anaconda 3.5 and get this error on testing:

…/anaconda3/lib/python3.5/site-packages/psi4/tests/ Segmentation fault: 11

yeah, I’ve seen it, too. unless you really want simint, pass cmake -DENABLE_simint=OFF (or edit CMakeCache.txt for same). Won’t hurt psi itself.

Sorry to bump an old thread, but this was the first search result and hit exactly what I was after.

I was victim of Illegal instruction: 4 when using the instructions on the main site. I tried the above fix with 3.5 instead of 3.6 and it installed with all tests passing (save a few that skipped because of things I didn’t I have installed). Then I tried the same in my root environment (conda install psi4 ssse41) and it also worked. I don’t know what all is in the 200 MB bash script, but it alone wasn’t enough to successfully install. Maybe it’s the sse, I didn’t see it in there.

Glad the direct conda install psi4 sse41 worked for you, @mwt. Correct that those packages should now be available for all three python versions. You’ll have a post 1.1 version (psi4 --version returns 1.2a1****) rather than exactly the 1.1 release that the 200 MB bash script/psi4 installer provides. The “old hdw” button should have worked for you, but if you’ve got a version you’re satisfied with, I don’t see any need to debug. Thanks for the report.

My Mac OS version is OS X 10.9.2 (13C64) and processor is MACcpu-Intel® Core™ i7-3720QM CPU @ 2.60GHz and I am getting the same error “Illegal instruction 4”. What should I do ?

use the “old hdw” (old hardware, pre-AVX) installer