Psi4conda-1.3.2-py37-Linux-x86_64 installation problem

Dear Psi4 Community,

when installing the subject I got the following error:

Psi4conda-1.3.2-py37-Linux-installing: psi4-rt-1.3.2-py37ha6b60c8_0 …
if: Expression Syntax.
then: Command not found.
ERROR: executing failed_64

When trying to run manually after this installation error, it says:
File “/home/leonid/psi4conda/bin/psi4”, line 177, in
import psi4
File “/home/leonid/psi4conda/lib//python3.7/site-packages/psi4/”, line 82, in
from .driver import endorsed_plugins
File “/home/leonid/psi4conda/lib//python3.7/site-packages/psi4/driver/”, line 33, in
from qcelemental import constants
ModuleNotFoundError: No module named ‘qcelemental’

I would appreciate any help.

I defer to @loriab on any errors during a conda installation.

Normally whenever you see a ModuleNotFoundError, a good first idea is to pip install the module it can’t find. qcelemental may be special because the version requirements seem to change frequently.

any chance you weren’t explicitly bashing the installer (i.e., bash Psi4conda-1.3.2...)? there’s a post-install script that moves “noarch” packages like qcelemental into the correct location (details and why upon request), and it’s looking like something very fundamental is going wrong. afaik this post-install step has been working fine for months, so your environment or execution are my first inquires.

I was doing exactly as written here
the installation was successful till the final step. I managed to install an earlier version
psi4conda-1.2.1-py27-Linux-x86_64 as the temporary solution which works fine.

The pip version was “You are using pip version 10.0.1”, so I updated it to 19.2.1, though haven’t tried to install the py37 version of psi4 yet.

let’s get a which conda python psi4, conda list, and psi4 --version, please. did you already have psi4 present by any means (installer/conda/clone) before starting the 1.3.2 installation? I’m wondering if your environment was set up for an older psi and the new psi is trying to run against that older (and for new psi4, incomplete) set of dependencies.